
环境VMware® Workstation 17 Pro 17.6.4 build-24832109debian-13.7.0-amd64-DVD-1.iso一、下载 debian可通过百度网盘下载链接: https://pan.baidu.com/s/1_1-Df532FHCbeficiDtt2Q?pwdtakh 提取码: takh也可以从官网下载https://www.debian.org/distrib/index.html下载完成后文件大小约为 3.7G如下图所示二、新建虚拟机至此新的虚拟机就创建完成了。三、 安装首先设置虚拟机的光驱点击这里继续后就自动重启虚拟机了。启动的时候有个选择项我没注意它自己跳过去了不用理它。现在我们可以先关机将光驱设置为空再重启下面的界面可以按回车也可以不按看到下图就启动成功了四、基本配置现在让我们用root登录4.1 先查看 ip远程登录拿到 ip 后我们就可以用ssh工具远程登录了这里我用finalshell:4.2 处理 apt 源先切换到管理员用户然后先尝试执行apt update报错这个错误是因为安装用的 dvd 导致系统把这个dvd文件当做源了。现在我们修改配置文件将源改为阿里的cat/etc/apt/sources.listEOF deb https://mirrors.aliyun.com/debian/ trixie main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian/ trixie-updates main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian/ trixie-backports main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian-security/ trixie-security main contrib non-free non-free-firmware EOF然后再执行apt update4.3 安装 vim默认安装只有vi没有vim我们安装它aptinstallvim-y4.4 安装 sudo默认安装只有su命令没有sudo, 我们安装它aptinstallsudo-y4.4 设置允许root账户远程登录默认root账户是不能远程登录的我们需要修改配置文件/etc/ssh/sshd_config:注意 生产环境慎重做法就是将 /etc/ssh/sshd_config 这个文件的 PermitRootLogin 这一行将其修改为 yes如# 查找并修改如果行首有#需要去掉注释 PermitRootLogin yes为了方便我们可以使用 sed 命令操作sudosed-is/^#\?PermitRootLogin.*/PermitRootLogin yes//etc/ssh/sshd_config如果命令没有输出说明语法正确。然后重启 SSH 服务使配置生效然后执行sudosystemctl daemon-reloadsudosystemctl restartssh然后就可以退出使用 root 账户登录了。4.5 检查时区配置timedatactl默认就是东八区就这样挺好。