ARTICLE DETAIL

资讯详情

深耕郑州网站建设与运营推广的一线实战洞察。

Linux - MySQL等常用软件部署

Linux - MySQL等常用软件部署 文章目录1 MySQL部署2 Redis部署3 learn部署1 MySQL部署安装步骤大致包括下载安装、修改配置文件、配置开机自启、安全向导和防火墙等参考教程Centos上安装Mysql5.7教程1. 下载安装//下载并安装Yum仓库sudowgethttps://dev.mysql.com/get/mysql57-community-release-el7-11.noarch.rpmsudorpm-ivhmysql57-community-release-el7-11.noarch.rpm //安装MySQLsudoyuminstallmysql-community-server-y//以上步骤会报错mysql-community-libs-5.7.44-1.el7.x86_64.rpm 的公钥尚未安装 //下载并导入MySQL的GPG公钥sudowgethttps://repo.mysql.com/RPM-GPG-KEY-mysql-2022sudorpm--importRPM-GPG-KEY-mysql-2022 //列出所有已导入的GPG密钥应输出类似内容gpg-pubkey-3a79bd29-5xxxxxxxsudorpm-qagpg-pubkey* //再次安装mysql-community-libs-5.7.44-1.el7.x86_64和MySQL5.7sudoyuminstallmysql-community-libs-5.7.44-1.el7.x86_64sudoyuminstallmysql-community-server-y2. 修改配置文件//修改绑定地址​ /etc/my.cnf[mysqld]bind-address0.0.0.0# 允许所有 IP 连接3. 配置开机自启、安全向导和防火墙//启动MySQL设置MySQL开机自启sudosystemctl start mysqldsudosystemctlenablemysqld //获取初始root密码​sudogreptemporary password/var/log/mysqld.log //尝试登录 会失败 mysql-uroot-p//运行安全配置向导​sudomysql_secure_installation //按提示操作 输入临时密码。 设置新密码需满足复杂度要求至少8位包含大小写字母、数字和符号。 123456Aa_ 删除匿名用户输入 Y。 禁止 root 远程登录输入 Y。 删除测试数据库输入 Y。 重新加载权限表输入 Y //尝试登录 123456Aa_ mysql-uroot-p//授权root用户远程访问​ //直接修改root用户的Host为% SELECT Host, User FROM mysql.user;UPDATE mysql.user SETHost%WHEREUserroot;FLUSH PRIVILEGES;//开放3306端口sudofirewall-cmd--zonepublic --add-port3306/tcp--permanentsudofirewall-cmd--reload//重启 即可root用户远程访问​sudosystemctl restart mysqld2 Redis部署安装步骤大致包括安装gcc、下载版本包、编译部署、修改配置文件、配置置开机自启和防火墙等参考教程Redis部署教程Redis部署教程Redis设置开机自启教程1. 安装gcc//安装gcc yuminstallgcc-c2. 下载编译部署//获取redis版本包wgethttps://download.redis.io/releases/redis-5.0.14.tar.gz //解压 编译 部署tar-zvxfredis-5.0.14.tar.gz-C/usr/localcd/usr/local/redis-5.0.14makemakePREFIX/usr/local/redis-5.0.14install3. 配置文件修改//修改配置文件vim/usr/local/redis-5.0.14/redis.conf 注释该行 行内容为:bind127.0.0.1 protected-mode no daemonizeyes4. 配置防火墙//停止与启动ps-ef|grepredis-server|grep-vgrep|awk-F {print $2}|xargskill-9./bin/redis-server ./redis.conf //配置防火墙放开sudofirewall-cmd--zonepublic --add-port6379/tcp--permanentsudofirewall-cmd--reload5. 配置开机自启//增加配置文件vim/usr/lib/systemd/system/redis.service //配置文件内容[Unit]Descriptionredis-serverAfternetwork.target[Service]TypeforkingExecStart/usr/local/redis-5.0.14/bin/redis-server /usr/local/redis-5.0.14/redis.confExecStop/usr/local/redis-5.0.14/bin/redis-clishutdownPrivateTmptrue[Install]WantedBymulti-user.target//重载系统服务 systemctl daemon-reload //启动 停止 重启 状态 设置开机自启 systemctl start redis systemctl stop redis systemctl restart redis systemctl status redis systemctlenableredis3 learn部署安装步骤大致包括本地调试、增加systemctl控制1. 本地调试//安装jdksudoyuminstall-yjava-1.8.0-openjdk-develjava-version//本地调试sudofirewall-cmd--zonepublic --add-port8088/tcp--permanentsudofirewall-cmd--reloadps-ef|greplearn-1.1.0.jar|grep-vgrep|awk-F {print $2}|xargskill-9java-Xms512m-Xmx512m-jarlearn-1.1.0.jar--spring.profiles.activedev./logs/stdout.log2. 增加systemctl控制//增加配置文件vim/usr/lib/systemd/system/learn.service //配置文件内容[Unit]DescriptionLearn Application ServiceAfternetwork.targetAftermysqld.service redis.service[Service]Typesimple# 基本启动命令ExecStart/bin/bash /home/learn/start.sh# ExecStart/usr/bin/java -Xms512m -Xmx512m -jar /home/learn/learn-1.1.0.jar --spring.profiles.activedev /home/learn/logs/stdout.log # ExecStart/usr/bin/java -jar /opt/myapp/myapp.jar --spring.config.location/etc/myapp/application.ymlWorkingDirectory/home/learnRestarton-failureRestartSec5UserrootGrouproot[Install]WantedBymulti-user.target //检查语法错误 systemd-analyze verify /usr/lib/systemd/system/learn.service //重载系统服务 systemctl daemon-reload
返回列表