
1.debuild 出现报错连接Dockers Hub 超时尝试过程如果直接装代理可以跳过直接到21.在虚拟机终端去到配置文件所在目录./Labsetup/执行下面检查DNS配置cat /etc/resolv.conf curl -I https://registry-1.docker.io/v2/ --max-time 10当前指向127.0.0.53本地stub但没有把DNS解析转发2.2.运行之后再次cat /etc/resolv.conf nslookup registry-1.docker.io结果图指明已将systemd-resolved的DNS指到公网判断resolved未生效or 外部DNS本身不可达结果显示外部到公网DNS的53端口不可达需要走代理2.给虚拟机挂代理确认外网不可达100%丢包默认NAT网关10.0.2.1先确认虚拟机设置中-网络-选择了NAT Network检查是否自己的电脑是需要通过代理才能上网ping后发现通了证明NAT内部没问题则问题出在NAT出口到外网1.检查本机的代理服务器地址端口号打开局域网连接端口号为78972.查找本机的局域网IPwinR 进入cmd命令输入ipconfig查找本地连接的网络找到IPv4的地址执行代码将HOST_IP替换成你查找的IP地址再执行下面的代码测Docker Hub域名结果图显示curl通过代理访问到Docker Registry3.1确认Docker 是否在用代理填入后ctrlo保存enterctrlx退出重启docker并测试连通性结果docker服务起不来查找失败原因结果发现存在不支持字段需要删除删掉带有字段registry-mirrors并保存退出再次重启docker应该可以成功了测试拉镜像出现以下报错Docker 没有通过配置的代理在工作出现 No such file or directory 则生效的drop-in文件不存在重新创建上面创建过但是失败了可能是个人操作原因并重启docker则会出现代理生效结果dcbuild后开始创建并可以创建成功dcup打开docker并新开一个终端输入 nc 10.9.0.80 3000当前终端保留